Skip to content

Commit

Permalink
kernel: bump 4.14 to 4.14.227
Browse files Browse the repository at this point in the history
Refreshed all patches.

Altered patches:
- 809-flexcan-support-layerscape.patch

Compile-tested on: ar71xx, cns3xxx, imx6, layerscape, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
  • Loading branch information
xback authored and Koen Vandeputte committed Apr 9, 2021
1 parent 81266d9 commit c43c434
Show file tree
Hide file tree
Showing 27 changed files with 75 additions and 75 deletions.
4 changes: 2 additions & 2 deletions include/kernel-version.mk
Original file line number Diff line number Diff line change
Expand Up @@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif

LINUX_VERSION-4.14 = .224
LINUX_VERSION-4.14 = .227

LINUX_KERNEL_HASH-4.14.224 = d83658ec4c60595f05c8c395aa3a6a39e0ccbd3a7abb5987b5a6b38f84f41cf5
LINUX_KERNEL_HASH-4.14.227 = 0722d3c4bc056ccee24d3d08792ba81b228a457ee4ed9c6f40bb1f407612e0c7

remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>

#include "xhci.h"
#include "xhci-trace.h"
@@ -276,6 +278,458 @@ static void xhci_pme_acpi_rtd3_enable(st
@@ -280,6 +282,458 @@ static void xhci_pme_acpi_rtd3_enable(st
static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
#endif /* CONFIG_ACPI */

Expand Down Expand Up @@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
/* called during probe() after chip reset completes */
static int xhci_pci_setup(struct usb_hcd *hcd)
{
@@ -314,6 +768,22 @@ static int xhci_pci_probe(struct pci_dev
@@ -318,6 +772,22 @@ static int xhci_pci_probe(struct pci_dev
struct hc_driver *driver;
struct usb_hcd *hcd;

Expand All @@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
driver = (struct hc_driver *)id->driver_data;

/* For some HW implementation, a XHCI reset is just not enough... */
@@ -375,6 +845,16 @@ static void xhci_pci_remove(struct pci_d
@@ -379,6 +849,16 @@ static void xhci_pci_remove(struct pci_d
{
struct xhci_hcd *xhci;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ produce a noisy warning.

--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
@@ -225,7 +225,7 @@ static void xhci_pci_quirks(struct devic
@@ -226,7 +226,7 @@ static void xhci_pci_quirks(struct devic
xhci->quirks |= XHCI_TRUST_TX_LENGTH;
if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
pdev->device == 0x0015)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -80,7 +80,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
static void nfnl_queue_net_exit_batch(struct list_head *net_exit_list)
--- a/net/netfilter/x_tables.c
+++ b/net/netfilter/x_tables.c
@@ -1785,8 +1785,17 @@ static int __net_init xt_net_init(struct
@@ -1787,8 +1787,17 @@ static int __net_init xt_net_init(struct
return 0;
}

Expand Down
8 changes: 4 additions & 4 deletions target/linux/generic/hack-4.14/721-phy_packets.patch
Original file line number Diff line number Diff line change
Expand Up @@ -15,23 +15,23 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -1412,6 +1412,7 @@ enum netdev_priv_flags {
@@ -1413,6 +1413,7 @@ enum netdev_priv_flags {
IFF_PHONY_HEADROOM = 1<<26,
IFF_MACSEC = 1<<27,
IFF_L3MDEV_RX_HANDLER = 1<<28,
+ IFF_NO_IP_ALIGN = 1<<29,
};

#define IFF_802_1Q_VLAN IFF_802_1Q_VLAN
@@ -1442,6 +1443,7 @@ enum netdev_priv_flags {
@@ -1443,6 +1444,7 @@ enum netdev_priv_flags {
#define IFF_RXFH_CONFIGURED IFF_RXFH_CONFIGURED
#define IFF_MACSEC IFF_MACSEC
#define IFF_L3MDEV_RX_HANDLER IFF_L3MDEV_RX_HANDLER
+#define IFF_NO_IP_ALIGN IFF_NO_IP_ALIGN

/**
* struct net_device - The DEVICE structure.
@@ -1728,6 +1730,11 @@ struct net_device {
@@ -1729,6 +1731,11 @@ struct net_device {
const struct xfrmdev_ops *xfrmdev_ops;
#endif

Expand All @@ -43,7 +43,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
const struct header_ops *header_ops;

unsigned int flags;
@@ -1802,6 +1809,10 @@ struct net_device {
@@ -1803,6 +1810,10 @@ struct net_device {
struct mpls_dev __rcu *mpls_ptr;
#endif

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -23,7 +23,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>

--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -826,6 +826,13 @@ struct xfrmdev_ops {
@@ -827,6 +827,13 @@ struct xfrmdev_ops {
};
#endif

Expand All @@ -37,7 +37,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
/*
* This structure defines the management hooks for network devices.
* The following hooks can be defined; unless noted otherwise, they are
@@ -1057,6 +1064,10 @@ struct xfrmdev_ops {
@@ -1058,6 +1065,10 @@ struct xfrmdev_ops {
* int (*ndo_bridge_dellink)(struct net_device *dev, struct nlmsghdr *nlh,
* u16 flags);
*
Expand All @@ -48,7 +48,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
* int (*ndo_change_carrier)(struct net_device *dev, bool new_carrier);
* Called to change device carrier. Soft-devices (like dummy, team, etc)
* which do not represent real hardware may define this to allow their
@@ -1281,6 +1292,8 @@ struct net_device_ops {
@@ -1282,6 +1293,8 @@ struct net_device_ops {
int (*ndo_bridge_dellink)(struct net_device *dev,
struct nlmsghdr *nlh,
u16 flags);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -15,15 +15,15 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -827,6 +827,7 @@ struct xfrmdev_ops {
@@ -828,6 +828,7 @@ struct xfrmdev_ops {
#endif

struct flow_offload;
+struct flow_offload_hw_path;

enum flow_offload_type {
FLOW_OFFLOAD_ADD = 0,
@@ -1064,8 +1065,15 @@ enum flow_offload_type {
@@ -1065,8 +1066,15 @@ enum flow_offload_type {
* int (*ndo_bridge_dellink)(struct net_device *dev, struct nlmsghdr *nlh,
* u16 flags);
*
Expand All @@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
* Adds/deletes flow entry to/from net device flowtable.
*
* int (*ndo_change_carrier)(struct net_device *dev, bool new_carrier);
@@ -1292,8 +1300,11 @@ struct net_device_ops {
@@ -1293,8 +1301,11 @@ struct net_device_ops {
int (*ndo_bridge_dellink)(struct net_device *dev,
struct nlmsghdr *nlh,
u16 flags);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -1771,6 +1771,8 @@ struct net_device {
@@ -1772,6 +1772,8 @@ struct net_device {
struct netdev_hw_addr_list mc;
struct netdev_hw_addr_list dev_addrs;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -24,7 +24,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>

--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -713,6 +713,16 @@ struct xps_map {
@@ -714,6 +714,16 @@ struct xps_map {
#define XPS_MIN_MAP_ALLOC ((L1_CACHE_ALIGN(offsetof(struct xps_map, queues[1])) \
- sizeof(struct xps_map)) / sizeof(u16))

Expand All @@ -41,7 +41,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
/*
* This structure holds all XPS maps for device. Maps are indexed by CPU.
*/
@@ -1258,6 +1268,9 @@ struct net_device_ops {
@@ -1259,6 +1269,9 @@ struct net_device_ops {
const struct sk_buff *skb,
u16 rxq_index,
u32 flow_id);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -539,7 +539,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>

--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -2349,7 +2349,8 @@ int register_netdevice_notifier(struct n
@@ -2350,7 +2350,8 @@ int register_netdevice_notifier(struct n
int unregister_netdevice_notifier(struct notifier_block *nb);

struct netdev_notifier_info {
Expand All @@ -549,15 +549,15 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
};

struct netdev_notifier_info_ext {
@@ -2381,6 +2382,7 @@ static inline void netdev_notifier_info_
@@ -2382,6 +2383,7 @@ static inline void netdev_notifier_info_
struct net_device *dev)
{
info->dev = dev;
+ info->extack = NULL;
}

static inline struct net_device *
@@ -2389,6 +2391,12 @@ netdev_notifier_info_to_dev(const struct
@@ -2390,6 +2392,12 @@ netdev_notifier_info_to_dev(const struct
return info->dev;
}

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -1340,7 +1340,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
while (ep_ring->dequeue != td->last_trb)
--- a/drivers/usb/host/xhci.c
+++ b/drivers/usb/host/xhci.c
@@ -1605,13 +1605,38 @@ static int xhci_urb_dequeue(struct usb_h
@@ -1615,13 +1615,38 @@ static int xhci_urb_dequeue(struct usb_h
ret = -ENOMEM;
goto done;
}
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -161,7 +161,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>

- reg = flexcan_read(&regs->mcr);
+ reg = priv->read(&regs->mcr);
reg |= FLEXCAN_MCR_HALT;
reg |= FLEXCAN_MCR_FRZ | FLEXCAN_MCR_HALT;
- flexcan_write(reg, &regs->mcr);
+ priv->write(reg, &regs->mcr);

Expand Down Expand Up @@ -527,7 +527,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>

flexcan_transceiver_disable(priv);
priv->can.state = CAN_STATE_STOPPED;
@@ -1209,26 +1226,26 @@ static int register_flexcandev(struct ne
@@ -1209,9 +1226,9 @@ static int register_flexcandev(struct ne
err = flexcan_chip_disable(priv);
if (err)
goto out_disable_per;
Expand All @@ -539,13 +539,13 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>

err = flexcan_chip_enable(priv);
if (err)
@@ -1223,16 +1240,16 @@ static int register_flexcandev(struct ne
goto out_chip_disable;

/* set freeze, halt and activate FIFO, restrict register access */
/* activate FIFO, restrict register access */
- reg = flexcan_read(&regs->mcr);
+ reg = priv->read(&regs->mcr);
reg |= FLEXCAN_MCR_FRZ | FLEXCAN_MCR_HALT |
FLEXCAN_MCR_FEN | FLEXCAN_MCR_SUPV;
reg |= FLEXCAN_MCR_FEN | FLEXCAN_MCR_SUPV;
- flexcan_write(reg, &regs->mcr);
+ priv->write(reg, &regs->mcr);

Expand All @@ -559,7 +559,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
if (!(reg & FLEXCAN_MCR_FEN)) {
netdev_err(dev, "Could not enable RX FIFO, unsupported core\n");
err = -ENODEV;
@@ -1256,8 +1273,12 @@ static void unregister_flexcandev(struct
@@ -1260,8 +1277,12 @@ static void unregister_flexcandev(struct
static const struct of_device_id flexcan_of_match[] = {
{ .compatible = "fsl,imx6q-flexcan", .data = &fsl_imx6q_devtype_data, },
{ .compatible = "fsl,imx28-flexcan", .data = &fsl_imx28_devtype_data, },
Expand All @@ -572,7 +572,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
{ /* sentinel */ },
};
MODULE_DEVICE_TABLE(of, flexcan_of_match);
@@ -1337,6 +1358,21 @@ static int flexcan_probe(struct platform
@@ -1341,6 +1362,21 @@ static int flexcan_probe(struct platform
dev->flags |= IFF_ECHO;

priv = netdev_priv(dev);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>

--- a/drivers/mmc/core/mmc.c
+++ b/drivers/mmc/core/mmc.c
@@ -1173,6 +1173,9 @@ static int mmc_select_hs400(struct mmc_c
@@ -1180,6 +1180,9 @@ static int mmc_select_hs400(struct mmc_c
goto out_err;

/* Switch card to DDR */
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -137,7 +137,7 @@ Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
sdr_set_bits(host->base + MSDC_CFG, MSDC_CFG_CKPDN);
while (!(readl(host->base + MSDC_CFG) & MSDC_CFG_CKSTB))
cpu_relax();
@@ -1620,12 +1673,17 @@ static int msdc_drv_probe(struct platfor
@@ -1622,12 +1675,17 @@ static int msdc_drv_probe(struct platfor
struct mmc_host *mmc;
struct msdc_host *host;
struct resource *res;
Expand All @@ -155,7 +155,7 @@ Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
/* Allocate MMC host for this device */
mmc = mmc_alloc_host(sizeof(struct msdc_host), &pdev->dev);
if (!mmc)
@@ -1689,11 +1747,15 @@ static int msdc_drv_probe(struct platfor
@@ -1691,11 +1749,15 @@ static int msdc_drv_probe(struct platfor
msdc_of_property_parse(pdev, host);

host->dev = &pdev->dev;
Expand All @@ -172,7 +172,7 @@ Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>

mmc->caps |= MMC_CAP_ERASE | MMC_CAP_CMD23;
/* MMC core transfer sizes tunable parameters */
@@ -1842,12 +1904,6 @@ static const struct dev_pm_ops msdc_dev_
@@ -1844,12 +1906,6 @@ static const struct dev_pm_ops msdc_dev_
SET_RUNTIME_PM_OPS(msdc_runtime_suspend, msdc_runtime_resume, NULL)
};

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -58,7 +58,7 @@ Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
sdr_set_field(host->base + PAD_CMD_TUNE,
MSDC_PAD_TUNE_CMDRRDLY,
host->hs400_cmd_int_delay);
@@ -1597,7 +1603,8 @@ static int msdc_execute_tuning(struct mm
@@ -1599,7 +1605,8 @@ static int msdc_execute_tuning(struct mm
struct msdc_host *host = mmc_priv(mmc);
int ret;

Expand Down
Loading

0 comments on commit c43c434

Please sign in to comment.