Skip to content

Commit

Permalink
chore(master): Release 0.56.0
Browse files Browse the repository at this point in the history
  • Loading branch information
AztecBot committed Sep 18, 2024
1 parent e417231 commit 2efd344
Show file tree
Hide file tree
Showing 8 changed files with 125 additions and 7 deletions.
8 changes: 4 additions & 4 deletions .release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
".": "0.55.1",
".": "0.56.0",
"yarn-project/cli": "0.35.1",
"yarn-project/aztec": "0.55.1",
"barretenberg": "0.55.1",
"barretenberg/ts": "0.55.1"
"yarn-project/aztec": "0.56.0",
"barretenberg": "0.56.0",
"barretenberg/ts": "0.56.0"
}
67 changes: 67 additions & 0 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,72 @@
# Changelog

## [0.56.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.55.1...aztec-packages-v0.56.0) (2024-09-18)


### ⚠ BREAKING CHANGES

* add support for u1 in the avm, ToRadix's radix arg is a memory addr ([#8570](https://github.com/AztecProtocol/aztec-packages/issues/8570))
* remove key registry ([#8613](https://github.com/AztecProtocol/aztec-packages/issues/8613))
* **avm:** dont compress public bytecode ([#8623](https://github.com/AztecProtocol/aztec-packages/issues/8623))
* **avm:** remove tag in NOT ([#8606](https://github.com/AztecProtocol/aztec-packages/issues/8606))

### Features

* Add `Expr::as_constructor` (https://github.com/noir-lang/noir/pull/5980) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Add `Expr::as_for` and `Expr::as_for_range` (https://github.com/noir-lang/noir/pull/6039) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Add `Expr::as_lambda` (https://github.com/noir-lang/noir/pull/6048) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Add support for u1 in the avm, ToRadix's radix arg is a memory addr ([#8570](https://github.com/AztecProtocol/aztec-packages/issues/8570)) ([1785737](https://github.com/AztecProtocol/aztec-packages/commit/178573738731e2e74e4119a035f913da39675d85))
* Allow visibility modifiers in struct definitions (https://github.com/noir-lang/noir/pull/6054) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* **avm:** Avm recursive TS/Noir integration ([#8531](https://github.com/AztecProtocol/aztec-packages/issues/8531)) ([dd09f05](https://github.com/AztecProtocol/aztec-packages/commit/dd09f057e97ac1bba7b3fbf29b50737ebe5ca76f)), closes [#7791](https://github.com/AztecProtocol/aztec-packages/issues/7791)
* **avm:** Avm recursive TS/Noir integration ([#8611](https://github.com/AztecProtocol/aztec-packages/issues/8611)) ([e417231](https://github.com/AztecProtocol/aztec-packages/commit/e4172318af81ac2ac8535c89d3e5afc72d33ba29))
* **avm:** Remove tag in NOT ([#8606](https://github.com/AztecProtocol/aztec-packages/issues/8606)) ([d5695fc](https://github.com/AztecProtocol/aztec-packages/commit/d5695fcde93cbfda3e45bfa03988a9e72f2dcb59))
* **avm:** Return oracle ([#8629](https://github.com/AztecProtocol/aztec-packages/issues/8629)) ([b6bc7c3](https://github.com/AztecProtocol/aztec-packages/commit/b6bc7c3f5064255480e3d4443471c2c50007d0ca))
* **avm:** Set avm circuit subgroup size ([#8537](https://github.com/AztecProtocol/aztec-packages/issues/8537)) ([3b78058](https://github.com/AztecProtocol/aztec-packages/commit/3b78058288edbbe18a2eb8c81de5576c8a9478ab))
* **docs:** Some small custom note stuff ([#8518](https://github.com/AztecProtocol/aztec-packages/issues/8518)) ([a098d41](https://github.com/AztecProtocol/aztec-packages/commit/a098d41ef0ba91beaf8b22a353bccd8e78bae5f5))
* Faster LSP by caching file managers (https://github.com/noir-lang/noir/pull/6047) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Implement `to_be_radix` in the comptime interpreter (https://github.com/noir-lang/noir/pull/6043) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* **metaprogramming:** Add `#[use_callers_scope]` (https://github.com/noir-lang/noir/pull/6050) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Only download non-pruned blocks ([#8578](https://github.com/AztecProtocol/aztec-packages/issues/8578)) ([ae26474](https://github.com/AztecProtocol/aztec-packages/commit/ae26474709e28116a38fd2c2773de39dfb6816ad))
* Partial notes log encoding ([#8538](https://github.com/AztecProtocol/aztec-packages/issues/8538)) ([5f5ec20](https://github.com/AztecProtocol/aztec-packages/commit/5f5ec2099782a64160c7b06ce2021d28c264e7e9))
* Remove key registry ([#8613](https://github.com/AztecProtocol/aztec-packages/issues/8613)) ([a668506](https://github.com/AztecProtocol/aztec-packages/commit/a6685067a0a5d17cbbc4cbfed4e78e364864ff51))
* Show test output when running via LSP (https://github.com/noir-lang/noir/pull/6049) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Update rollup storage to hold pending/proven tips ([#8583](https://github.com/AztecProtocol/aztec-packages/issues/8583)) ([38e3051](https://github.com/AztecProtocol/aztec-packages/commit/38e3051d60f9f8a80e33fab4e0f7f3ec3cde2ee2))
* Use new IVC scheme ([#8480](https://github.com/AztecProtocol/aztec-packages/issues/8480)) ([1c7b06d](https://github.com/AztecProtocol/aztec-packages/commit/1c7b06d6621d9873f84147b2b7f1f22bf21bbacb))
* **vc:** Remove viem signers from validator client ([#8517](https://github.com/AztecProtocol/aztec-packages/issues/8517)) ([8244fa2](https://github.com/AztecProtocol/aztec-packages/commit/8244fa2d496975bb8bcc032690e0eab1b8c9548f))
* Visibility for traits (https://github.com/noir-lang/noir/pull/6056) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))


### Bug Fixes

* Address a bunch of issues with generics ([#8625](https://github.com/AztecProtocol/aztec-packages/issues/8625)) ([94718f1](https://github.com/AztecProtocol/aztec-packages/commit/94718f1fbc26b165107872b2e32ba5412ba3b7fd))
* Boomerang variable in sha256 hash function ([#8581](https://github.com/AztecProtocol/aztec-packages/issues/8581)) ([f2a1330](https://github.com/AztecProtocol/aztec-packages/commit/f2a13309f544bbd83b593e6a6207d49d9ef48b74))
* Error on `&mut x` when `x` is not mutable (https://github.com/noir-lang/noir/pull/6037) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Fix canonicalization bug (https://github.com/noir-lang/noir/pull/6033) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Fixes mapTuple typing ([#8615](https://github.com/AztecProtocol/aztec-packages/issues/8615)) ([25d5805](https://github.com/AztecProtocol/aztec-packages/commit/25d5805db1a2ccd0f06f14ab9a11a3fa455e5b69))
* Let LSP suggest fields and methods in LValue chains (https://github.com/noir-lang/noir/pull/6051) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Parse a statement as an expression (https://github.com/noir-lang/noir/pull/6040) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Prevent check_can_mutate crashing on undefined variable (https://github.com/noir-lang/noir/pull/6044) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* **world_state:** Fix race conditions in WorldState and IndexedTree ([#8612](https://github.com/AztecProtocol/aztec-packages/issues/8612)) ([6797525](https://github.com/AztecProtocol/aztec-packages/commit/679752542edf1667d58e8839aca05d2b9fcc7da6))


### Miscellaneous

* Add more cases for assert_equal conversion ([#8446](https://github.com/AztecProtocol/aztec-packages/issues/8446)) ([e3ea298](https://github.com/AztecProtocol/aztec-packages/commit/e3ea298fd1f7326199e6e35b3523aadb2b12a925))
* Archiver cleanup ([#8599](https://github.com/AztecProtocol/aztec-packages/issues/8599)) ([184cc88](https://github.com/AztecProtocol/aztec-packages/commit/184cc882b3f1b90d74f149e46100474263a3665d))
* **avm:** Dont compress public bytecode ([#8623](https://github.com/AztecProtocol/aztec-packages/issues/8623)) ([353da3f](https://github.com/AztecProtocol/aztec-packages/commit/353da3f65e34783058d3ec7187dbe876f737b044))
* **avm:** Simplify bb-prover and other AVM tests ([#8627](https://github.com/AztecProtocol/aztec-packages/issues/8627)) ([0d75363](https://github.com/AztecProtocol/aztec-packages/commit/0d7536395f2406a22a76f15d01114730c84edc18))
* **bb readme:** Document how to Honk Noir programs ([#7638](https://github.com/AztecProtocol/aztec-packages/issues/7638)) ([cd46ddd](https://github.com/AztecProtocol/aztec-packages/commit/cd46ddd96539f2db466d1116dabdb838d2a807e7))
* **ci:** Make boxes only run on master ([#8604](https://github.com/AztecProtocol/aztec-packages/issues/8604)) ([07e6a7e](https://github.com/AztecProtocol/aztec-packages/commit/07e6a7e36626f51f987fff1962903c86df34eb5b))
* **ci:** Remove deleted e2e ([#8600](https://github.com/AztecProtocol/aztec-packages/issues/8600)) ([03127b2](https://github.com/AztecProtocol/aztec-packages/commit/03127b29c9bcad21ff35c14aecf9b2402faa20a5))
* Create a Gemini prover ([#8622](https://github.com/AztecProtocol/aztec-packages/issues/8622)) ([94339fb](https://github.com/AztecProtocol/aztec-packages/commit/94339fbfc7c0c822dc1497c113d48f74a89f1bad))
* Delete eth-log-hander ([#8598](https://github.com/AztecProtocol/aztec-packages/issues/8598)) ([4064e90](https://github.com/AztecProtocol/aztec-packages/commit/4064e90c7455d1f06590635678f0588706bce328))
* Document array methods (https://github.com/noir-lang/noir/pull/6034) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Fix docs (https://github.com/noir-lang/noir/pull/6035) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Protogalaxy recursive verifier matches native verifier ([#8568](https://github.com/AztecProtocol/aztec-packages/issues/8568)) ([a4f61b3](https://github.com/AztecProtocol/aztec-packages/commit/a4f61b39c39bf01a1071b52bbf042408f29d5564))
* Rename CustomAtrribute to CustomAttribute (https://github.com/noir-lang/noir/pull/6038) ([7ea4709](https://github.com/AztecProtocol/aztec-packages/commit/7ea4709743aaaf2768d35d92cad3fbd4a8404fb0))
* Replace relative paths to noir-protocol-circuits ([1bd828f](https://github.com/AztecProtocol/aztec-packages/commit/1bd828f57fea834d8a04e9261c92b2378c5c0fd5))
* Use random ports in p2p_client tests ([#8624](https://github.com/AztecProtocol/aztec-packages/issues/8624)) ([650a241](https://github.com/AztecProtocol/aztec-packages/commit/650a241faee7d2c9be5d0ea071b26b275fb09b39))

## [0.55.1](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.55.0...aztec-packages-v0.55.1) (2024-09-17)


Expand Down
32 changes: 32 additions & 0 deletions barretenberg/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,37 @@
# Changelog

## [0.56.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.55.1...barretenberg-v0.56.0) (2024-09-18)


### ⚠ BREAKING CHANGES

* add support for u1 in the avm, ToRadix's radix arg is a memory addr ([#8570](https://github.com/AztecProtocol/aztec-packages/issues/8570))
* **avm:** remove tag in NOT ([#8606](https://github.com/AztecProtocol/aztec-packages/issues/8606))

### Features

* Add support for u1 in the avm, ToRadix's radix arg is a memory addr ([#8570](https://github.com/AztecProtocol/aztec-packages/issues/8570)) ([1785737](https://github.com/AztecProtocol/aztec-packages/commit/178573738731e2e74e4119a035f913da39675d85))
* **avm:** Avm recursive TS/Noir integration ([#8531](https://github.com/AztecProtocol/aztec-packages/issues/8531)) ([dd09f05](https://github.com/AztecProtocol/aztec-packages/commit/dd09f057e97ac1bba7b3fbf29b50737ebe5ca76f)), closes [#7791](https://github.com/AztecProtocol/aztec-packages/issues/7791)
* **avm:** Avm recursive TS/Noir integration ([#8611](https://github.com/AztecProtocol/aztec-packages/issues/8611)) ([e417231](https://github.com/AztecProtocol/aztec-packages/commit/e4172318af81ac2ac8535c89d3e5afc72d33ba29))
* **avm:** Remove tag in NOT ([#8606](https://github.com/AztecProtocol/aztec-packages/issues/8606)) ([d5695fc](https://github.com/AztecProtocol/aztec-packages/commit/d5695fcde93cbfda3e45bfa03988a9e72f2dcb59))
* **avm:** Set avm circuit subgroup size ([#8537](https://github.com/AztecProtocol/aztec-packages/issues/8537)) ([3b78058](https://github.com/AztecProtocol/aztec-packages/commit/3b78058288edbbe18a2eb8c81de5576c8a9478ab))
* Use new IVC scheme ([#8480](https://github.com/AztecProtocol/aztec-packages/issues/8480)) ([1c7b06d](https://github.com/AztecProtocol/aztec-packages/commit/1c7b06d6621d9873f84147b2b7f1f22bf21bbacb))


### Bug Fixes

* Boomerang variable in sha256 hash function ([#8581](https://github.com/AztecProtocol/aztec-packages/issues/8581)) ([f2a1330](https://github.com/AztecProtocol/aztec-packages/commit/f2a13309f544bbd83b593e6a6207d49d9ef48b74))
* **world_state:** Fix race conditions in WorldState and IndexedTree ([#8612](https://github.com/AztecProtocol/aztec-packages/issues/8612)) ([6797525](https://github.com/AztecProtocol/aztec-packages/commit/679752542edf1667d58e8839aca05d2b9fcc7da6))


### Miscellaneous

* Add more cases for assert_equal conversion ([#8446](https://github.com/AztecProtocol/aztec-packages/issues/8446)) ([e3ea298](https://github.com/AztecProtocol/aztec-packages/commit/e3ea298fd1f7326199e6e35b3523aadb2b12a925))
* **avm:** Simplify bb-prover and other AVM tests ([#8627](https://github.com/AztecProtocol/aztec-packages/issues/8627)) ([0d75363](https://github.com/AztecProtocol/aztec-packages/commit/0d7536395f2406a22a76f15d01114730c84edc18))
* **bb readme:** Document how to Honk Noir programs ([#7638](https://github.com/AztecProtocol/aztec-packages/issues/7638)) ([cd46ddd](https://github.com/AztecProtocol/aztec-packages/commit/cd46ddd96539f2db466d1116dabdb838d2a807e7))
* Create a Gemini prover ([#8622](https://github.com/AztecProtocol/aztec-packages/issues/8622)) ([94339fb](https://github.com/AztecProtocol/aztec-packages/commit/94339fbfc7c0c822dc1497c113d48f74a89f1bad))
* Protogalaxy recursive verifier matches native verifier ([#8568](https://github.com/AztecProtocol/aztec-packages/issues/8568)) ([a4f61b3](https://github.com/AztecProtocol/aztec-packages/commit/a4f61b39c39bf01a1071b52bbf042408f29d5564))

## [0.55.1](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.55.0...barretenberg-v0.55.1) (2024-09-17)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/cpp/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
project(
Barretenberg
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
VERSION 0.55.1 # x-release-please-version
VERSION 0.56.0 # x-release-please-version
LANGUAGES CXX C
)
# Insert version into `bb` config file
Expand Down
7 changes: 7 additions & 0 deletions barretenberg/ts/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,12 @@
# Changelog

## [0.56.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.55.1...barretenberg.js-v0.56.0) (2024-09-18)


### Features

* Use new IVC scheme ([#8480](https://github.com/AztecProtocol/aztec-packages/issues/8480)) ([1c7b06d](https://github.com/AztecProtocol/aztec-packages/commit/1c7b06d6621d9873f84147b2b7f1f22bf21bbacb))

## [0.55.1](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.55.0...barretenberg.js-v0.55.1) (2024-09-17)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/ts/package.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
"name": "@aztec/bb.js",
"packageManager": "yarn@1.22.22",
"version": "0.55.1",
"version": "0.56.0",
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
"license": "MIT",
"type": "module",
Expand Down
12 changes: 12 additions & 0 deletions yarn-project/aztec/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,17 @@
# Changelog

## [0.56.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.55.1...aztec-package-v0.56.0) (2024-09-18)


### ⚠ BREAKING CHANGES

* remove key registry ([#8613](https://github.com/AztecProtocol/aztec-packages/issues/8613))

### Features

* Remove key registry ([#8613](https://github.com/AztecProtocol/aztec-packages/issues/8613)) ([a668506](https://github.com/AztecProtocol/aztec-packages/commit/a6685067a0a5d17cbbc4cbfed4e78e364864ff51))
* Update rollup storage to hold pending/proven tips ([#8583](https://github.com/AztecProtocol/aztec-packages/issues/8583)) ([38e3051](https://github.com/AztecProtocol/aztec-packages/commit/38e3051d60f9f8a80e33fab4e0f7f3ec3cde2ee2))

## [0.55.1](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.55.0...aztec-package-v0.55.1) (2024-09-17)


Expand Down
2 changes: 1 addition & 1 deletion yarn-project/aztec/package.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
{
"name": "@aztec/aztec",
"version": "0.55.1",
"version": "0.56.0",
"type": "module",
"exports": {
".": "./dest/index.js"
Expand Down

0 comments on commit 2efd344

Please sign in to comment.